• October 22, 2019, 02:31:23 am
• Welcome, Guest. Please login or register.
Did you miss your activation email?

!!

TEMAC Forum Guests

Please take the time to Register for the forum, especially if you are a TEMAC club member.

This is one of the most active RC club forums in Ontario. Please participate in the discussion to help our great club to continue to grow.

Author Topic: I think my DX9 is dying...(or maybe it's my memory that's going!)  (Read 151 times)

0 Members and 1 Guest are viewing this topic.

Offline Wingnutz

  • Ace
  • *****
  • Posts: 908
  • Karma: +8/-0
  • Real Name: Bill Quantock
  • TEMAC #: 122
I think my DX9 is dying...(or maybe it's my memory that's going!)
« on: September 15, 2019, 08:08:11 pm »
Been flying this tx since 2013 and it's been pretty much trouble free.
Today however, it refuses to connect to any of my models, one of which worked yesterday and several of which have flown in the last week or so.
Turn on tx, select appropriate model, plug in model (batteries are good) and ...nothing at the model...no rx light, no esc music, no control response....
I've backedup the model settings on an SD card just in case...using Lemon rx's but to date they have been reliable.
Have I missed something?
 


DOWN WITH GRAVITY!

Offline davidk

  • Captain
  • ****
  • Posts: 255
  • Karma: +0/-0
  • Real Name: David Kates
  • TEMAC #: 351
  • Started Flying RC: 2019
Re: I think my DX9 is dying...(or maybe it's my memory that's going!)
« Reply #1 on: September 15, 2019, 08:48:04 pm »
Does the orange Spectrum logo light on the front of the TX light up and remain solid?

Does the logo light flicker at all... at any time?

Can you re-bind to a model?

Offline Wingnutz

  • Ace
  • *****
  • Posts: 908
  • Karma: +8/-0
  • Real Name: Bill Quantock
  • TEMAC #: 122
Re: I think my DX9 is dying...(or maybe it's my memory that's going!)
« Reply #2 on: September 18, 2019, 05:13:30 pm »
Think I’ve figured out what I did wrong.
When you turn the DX9 off, it takes several seconds to power down. If the TX is turned back on before the power down is complete, the start up procedure may not complete normally. If I’m patient on power down and start up and watch the logo light as David suggested, the transmitter behaves normally.
Thanks David.
DOWN WITH GRAVITY!